Linguagem Algoritma - Pseudocódigo - Studium Focus
Headlines News :
Home » » Linguagem Algoritma - Pseudocódigo

Linguagem Algoritma - Pseudocódigo

Written By Jonatas Alves on sábado, 29 de abril de 2017 | 19:02

Esta forma de representação de algoritmos também é conhecida como português estruturado ou portugol. É rica em detalhes e, por assemelhar-se à forma em que os programas são escritos é a maior utilizada.
Observe a tabela abaixo:



Algoritmo "<nome_do_algoritmo>"
 Algoritmo é uma palavra que indica o início da definição de um algoritmo em forma de pseudocódigo.
<nome_do_algoritmo> é um nome simbólico dado ao algoritmo

<declaração_de_variáveis>
<declaração_de_variáveis> consiste na seção onde são declaradas as variáveis globais usadas no algoritmo. 

<subalgoritmos>
<subalgoritmos> consiste nas seções opcionais do pseudocódigo onde são definidos os subalgoritmos. 
 início
 Início é a palavra que delimitam o início do conjunto de instruções do corpo do algoritmo.
 <corpo do algoritmo>
 São as instruções
 fimalgoritmo
 Fim é a palavra que delimitam o final do conjunto de instruções do corpo do algoritmo.

O exemplo abaixo calcula a média aritmética de um aluno.

algoritmo "Calcula-média"
var
                                N1, N2, N3,  N4, MÉDIA, SOMA: real

início
                   // ----------ENTRADA DE DADOS----------

                  leia (N1, N2, N3, N4)

                  // ---------- PROCESSAMENTO----------

                  SOMA <- N1 + N2 + N3 + N4
                  MÉDIA <- SOMA / 4

                  // ----------SAÍDA----------
                 escreva ("Média Final: ", Média)

fim Algoritmo

Exemplo de algoritmo que determina se uma pessoa é maior ou menor de idade

Algoritmo "Maioridde"
var
              idade: inteiro
início
      // ----------ENTRADA DE DADOS----------
      escreva ("Digite a idade (maior do que zero): ")
      leia (idade)

     // ----------SAÍDA----------
     se (idade > 0) então
         escreva ("Maior de idade.")
     senão
        escreva ("Menor de idade.")
    fimse

senão
   Escreva (" Idade incorreta,")
Fimse

fmalgoritmo



Share this article :

0 comentários:

Fale o que está na sua mente

Diga-nos o que você está pensando ...!

Template Information

 
Support : Creating Website | Johny Template | Mas Template
Proudly powered by Blogger
Copyright © 2011. Studium Focus - All Rights Reserved
Original Design by Creating Website Modified by Adiknya