Algoritmos - Estrutura Condicional Simples - Studium Focus
Headlines News :
Home » » Algoritmos - Estrutura Condicional Simples

Algoritmos - Estrutura Condicional Simples

Written By Jonatas Alves on quinta-feira, 15 de junho de 2017 | 13:29

A estrutura condicional simples descrevem ações que serão executadas somente quando a expressão lógica for satisfeita.

Sintaxe:
se <condição> então
    <bloco de comando>
fimse

A <condição> é uma expressão que deverá retornar um valor de verddeiro (V) ou de falso (F), e caso o resultado dessa expressão seja verdadeiro, será executado o bloco de comandos que está dentro da estrutura. Caso seja falso, a execução do programa ignora o bloco de comando e continua na linha seguinte à estrutura de condição.
O <bloco de comando> é uma sequência de códigos que será executado somente quando o resultado da expressão lógica for verdadeiro.

Exemplo1:
Tem por função comparar se o valor de X é maior que o valor de Y.

X <- 20
Y <- 10
se (X > Y) entao
        Escreva ("O valor de X é maior que o valor de Y")
fimse

Exemplo 2:
Condição: verifica se a idade da pessoa é maior ou igual a 18.

Algoritmo "Eexemplo2"

var
    idade: inteiro

inicio
Escreva ("Digite a sua idade")
Leia(idade)

se idade >= 18 entao
      Escreva ("Você é maior de idade")
fimse


fimalgoritmo
Share this article :

0 comentários:

Fale o que está na sua mente

Diga-nos o que você está pensando ...!

Template Information

 
Support : Creating Website | Johny Template | Mas Template
Proudly powered by Blogger
Copyright © 2011. Studium Focus - All Rights Reserved
Original Design by Creating Website Modified by Adiknya