Exercícios Visual G - Studium Focus
Headlines News :
Home » » Exercícios Visual G

Exercícios Visual G

Written By Jonatas Alves on sábado, 10 de junho de 2017 | 22:28


Exercicios
1 - Faça um algoritmo que receba dois números e mostre o resultado de sua soma.
Algoritmo "Exercicio01"

Var
// Seção de Declarações das variáveis
n1, n2:inteiro

Inicio
// Seção de Comandos
Escreval("Digite o primeiro número:")
Leia(n1)
Escreval("Digite o segundo número:")
Leia(n2)
Escreval("A soma dos números é: ",n1+n2)

Fimalgoritmo

2 - Faça um algaritmo que receba dois numéros e ao final mostre a soma, a subtração, a multiplicação e a divisão dos numéros lidos.

Algoritmo "Exercicio02"

Var
// Seção de Declarações das variáveis
 n1, n2: inteiro

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc...
Escreva("Digite o primeiro numéro:")
Leia(n1)
Escreva("Digite o segundo numéro:")
Leia(n2)
Escreval("A soma é: ",n1+n2)
Escreval("A subtração é:",n1-n2)
Escreval("A multiplicação é:",n1*n2)
Escreval("A divisão é:",n1/n2)

Fimalgoritmo

3 - Escreva um algoritmo para determinar o consumo médio de um automóvel sendo fornecido a distância total percorrida pelo veículo e o total de combustivel gasto.

Algoritmo "Exercicio03"

Var
// Seção de Declarações das variáveis 
 distancia, combustivel:real

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc... 
 Escreva("Digite a distância percorrida:")
 Leia(distancia)
 Escreva("Digite o combustivel gasto:")
 Leia(combustivel)
 Escreval("O consumo médio de combustivel do seu veículo é:",distancia/combustivel)

Fimalgoritmo

4 - Escreva um algoritmo que leia o nome de um vendedor, o seu salário fixo e o total de vendas em dinheiro efetuada por ele no mês. Sabendo que este vendedor ganha 15% ded comissão sobre suas vendas efetuadas, informar o seu nome, o salario fixo e salário no final do mês.

Algoritmo "exercicio04"

var
nome: caractere
salario: real
vendas: real
comissao: real
salarioFinal: real

inicio
// Seção de Comandos
escreva(">>> Digite o nome do vendedor: ")
leia(nome)
escreva(">>> Digite o salário: ")
leia(salario)
escreva(">>> Informe a quantidade de vendas do mês: ")
leia(vendas)
comissao <- 0.15 * vendas
salarioFinal <- salario + comissao
escreval("Nome: ",nome)
escreval("Salário: ",salario)
escreval("Salário Final (salário + comissão): ",salarioFinal)

fimalgoritmo

5 - Uma escola pretende realizar o pagamento de seus professores por hora/aulas. Faça um algorimo que mostre o salário de cada professor da escola. Sabendo-se que o valor da hora/aula segue os dados abaixo:
Professor nivel 1 R$ 50,00 hora/aula
Professor nivel 2 R$ 70,00 hora/aula
Professor nivel 3 R$ 100,00 hora/aula

Algoritmo "Exercicio03"

Var
// Seção de Declarações das variáveis 
nivel, horas: inteiro

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc... 
escreva("Digite o nível do professor: ")
leia(nivel)
escreva("Digite o número de horas trabalhadas: ")
leia(horas)

se nivel = 1 entao
    escreval("O professor ganha",horas*50)
senao
    se nivel = 2 entao
        escreval("O professor ganha",horas*70)
    senao
        escreva("O professor ganha",horas*100)
    fimse
fimse

Fimalgoritmo

6 -  Desenvolver um algoritmo para dado dois times de futebol (cada time identificado por um número inteiro), seus pontos ganhos no campeonato, decidir qual dos dois times é o ganhador. A regra diz que o ganhador é o time que tiver mais pontos ganhos.

Algoritmo "Exercicio06"

Var
// Seção de Declarações das variáveis 
time01,time02:inteiro
pontosTime01,pontosTime02:inteiro

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc... 
escreva("Digite o número do primeiro time:")
Leia(time01)
Escreva("Digite o número do segundo time:")
Leia(time02)
Escreva("Digite os pontos do primeiro time:")
Leia(pontosTime01)
Escreva("Digite os pontos do segundo time:")
Leia(pontosTime02)
Se (pontosTime01 > pontosTime02) Entao
Escreva("O time:",time01," é o Ganhador")
Senao
Escreva("O time:",time02," é o Ganhador")
FimSe

Fimalgoritmo

7 - Faça um  algoritmo que leia a idade de uma pessoa e informe a sua classe eleitoral conforme os dados abaixo:
  • Não eleitor abaixo de 16 anos;
  • Eleitor obrigatório entre 18 e 65 anos;
  • eleitor facultativo entre 16 e 18 anos e maior de 65 anos.

Algoritmo "Exercicio07"

Var
// Seção de Declarações das variáveis 
 idade: inteiro

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc... 
 Escreva("Digite a sua idade: ")
  Leia(idade)
  Se (idade < 16) Entao
     Escreva("NÃO É ELEITOR")
  Senao
     Se(idade >= 18) E (idade <= 65) Entao
         Escreva("ELEITOR OBRIGATÓRIO")
     Senao
         Escreva("ELEITOR FACULTATIVO")
     FimSe
  FimSe

Fimalgoritmo

8 - Um plano de saúde, após as negociações com o governo enviou a tabela abaixo.
  • Até 10 anos: R$ 30,00
  • De 10 anos até 29 anos R$ 60,00
  • De 29 anos até 45 anos R$ 120,00
  • De 45 anos até 59 anos R$ 150,00
  • De 59 anos até 65 anos R$ 250,00
  • Maior que 65 anos R$ 250,00


Algoritmo "Exercicio8"

Var
// Seção de Declarações das variáveis 
nome: caractere
idade: inteiro

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc... 
Escreva("Digite o nome: ")
Leia(nome)
Escreva("Digite a idade: ")
Leia(idade)
Se(idade < 10)Entao
   Escreva("R$ 30,00")
Senao
   Se(idade < 29)Entao
      Escreva("R$ 60,00")
   Senao
      Se(idade < 45)Entao
         Escreva("R$ 120,00")
      Senao
         Se(idade < 59)Entao
            Escreva("R$ 150,00")
         Senao
            Se(idade < 65)Entao
               Escreva("R$ 250,00")
            Senao
               Escreva("R$ 400,00")
            FimSe
         FimSe
      FimSe
   FimSe
FimSe

Fimalgoritmo



Share this article :

0 comentários:

Fale o que está na sua mente

Diga-nos o que você está pensando ...!

Template Information

 
Support : Creating Website | Johny Template | Mas Template
Proudly powered by Blogger
Copyright © 2011. Studium Focus - All Rights Reserved
Original Design by Creating Website Modified by Adiknya