Atividades Algoritmos - Studium Focus
Headlines News :
Home » » Atividades Algoritmos

Atividades Algoritmos

Written By Jonatas Alves on domingo, 28 de maio de 2017 | 19:43


1. Faça um algoritmo que receba o valor de um depósito e o valor da taxa de juros, calcule e mostre o valor do rendimento e o valor total depois do rendimento.

Algoritmo "ValorDeposito"

Var
deposito,taxa, rendimento,total:real
Inicio
Escreva("Digite o valor do depósito:")
Leia(deposito)
Escreva("Digite o valor da taxa de juros:")
Leia(taxa)
rendimento <- deposito*(taxa/100)
Total <-deposito + Rendimento
Escreva("O valor do rendimento é:", rendimento)
Escreva("O valor total após o rendimento é:", total)
Fimalgoritmo


2. Faça um algoritmo que receba o seu ano de nascimento atual. Calcule e mostre:
A) A sua idade.
b) Quantos terá no ano 3000.

Algoritmo "IdadeFuturo"

Var
aNasc,aAtual,idPres,idFut: inteiro

Inicio
Escreva("Digite o ano que você nasceu:")
Leia(aNasc)
Escreva("Digite o ano atual:")
Leia(aAtual)
idPres <- (aAtual-aNasc)
idFut <- (3000 - aNasc)
Escreval("A sua idade é:",idPres)
Escreval("A idade que terá no ano 3000 será:",idFut)
Fimalgoritmo

3. Faça um algoritmo que leia o ano de nascimento de uma pessoa, calcule e mostre sua idade e, também, verifique e mostre se ela já tem idade para votar (16 anos ou mais) e para conseguir a Carteira de Habilitação (18 anos ou mais).

var
dia,mes,ano,dia_atual,mes_atual,ano_atual,idade: inteiro

Inicio
 Escreva("Informe a data atual")
 Escreva("Dia:")
 Leia(dia_atual)
 Escreva("Mês:")
 Leia(mes_atual)
 Escreva("Ano:")
 Leia(ano_atual)

 Escreva("Dia do nascimento:")
 Leia(dia)
 Escreva("Mês do nascimento:")
 Leia(mes)
 Escreva("Ano do nascimento:")
 Leia(ano)

 se mes_atual >= mes entao
 se dia_atual >=dia entao
 idade <- ano_atual - ano
 senao
 idade <- ano_atual - ano - 1
 fimse
 senao
 idade <- ano_atual - ano - 1
 fimse

 escreval("Você tem",idade,"anos.")

 se idade >= 16 entao
 escreval("Você já pode votar!")
 fimse

 se idade >= 18 entao
 escreval("Você já pode tirar carteira de habilitação!")
 fimse

Fimalgoritmo
Share this article :

0 comentários:

Fale o que está na sua mente

Diga-nos o que você está pensando ...!

Template Information

 
Support : Creating Website | Johny Template | Mas Template
Proudly powered by Blogger
Copyright © 2011. Studium Focus - All Rights Reserved
Original Design by Creating Website Modified by Adiknya